Accueil > Pas demain la veille > Spipophone > SPIP 2.0.10 n’est pas un fantôme…

SPIP 2.0.10 n’est pas un fantôme…

mardi 3 novembre 2009, par polatouche

Pendant que les humains dorment, les esprits veillent… La preuve, une nouvelle mouture toute fraîche de SPIP pour Halloween : la 2.0.10, à ne pas confondre avec la 2.1.00…

SPIP 2.0.10 pour Haloween

Bonjour,

une nouvelle version de SPIP est disponible. Elle contient de nombreuses corrections et améliorations par rapport à la 2.0.9. Nous vous conseillons de mettre à jour.

Vous pouvez télécharger cette version sur le site de SPIP : http://www.spip.net/fr_download

A bientôt L’équipe de SPIP

Les nouveautés de la 2.0.10

- 14367 et 14368 : appliquer les traitements automatiques sur le #TEXTE d’un message de forum
- 14392 et 14483 : ajouter $table_titre (utile pour la génération d’urls) dans le pipeline "declarer_tables_interfaces"
- 14393, 14394 et 14519 : mettre à jour toutes les dates de la branche de rubriques lors de la publication d’un article y compris avec la configuration par défaut "Ne pas publier les articles avant la date de publication fixée."
- 14399 : éviter l’affichage de "Array" dans la page des statistiques
- 14400 : éviter l’affichage intempestif de "_DOCTYPE_ECRIRE"
- 14409 : éviter l’erreur de connexion à un serveur nommé "int"
- 14413 : corriger l’appel à la version PostGres de listdbs
- 14433 : éviter les erreurs lors du passage d’un tableau en paramètre d’url
- 14442 : valider en XHTML strict #MENU_LANG
- 14445 : corriger le filtre form_hidden qui ne passe désormais que ce qui est nécessaire : la recherche ne retourne plus de résultats erronés
- 14451 : éviter l’erreur php "Call to undefined function gzcompress"
- 14470 : ne pas créer par défaut de répertoire xxx.plat qui peuvent provoquer des erreurs incompréhensibles
- 14471 : corriger le menu "afficher visiteurs"
- 14476 : faire fonctionner les paginations appelées par un modèle inclus dans du texte d’un article
- 14479 et 14670 : corriger le serveur lorsqu’une surcharge de l’installation comporte un appel à un serveur externe ; possibilité de déclaration de bases externes dans ecrire/ ?exec=admin_tech
- 14481 : en attendant mieux ? on remet le find_in_path() sur connect/$serveur.php qui permet le hack des boucles POUR et cons¦urs
- 14484, 14489 et 14521 : passer systématiquement la variable serveur pour parler à deux connexions en même temps (sinon, seule la dernière connexion ouverte parle)
- 14487 et 14566 : permettre l’enregistrement de la première révision dans le cas d’une reprise et signaler que le code de premiere_revision est à réviser
- 14488 : envoyer la date (de publication) avec le statut dans le pipeline notification lorsque l’on institue
- 14490 : corriger charger_fonction : ne pas ajouter de tiret si le dossier est vide
- 14491 : éviter les explosions mémoire en passant par un fichier temporaire pour dézipper
- 14495 et 14499 : renvoyer le nombre de lignes affectées par sql_delete (ou false) en cas d’erreur. 14497 : ajouter un define pour indiquer dans l’espace privé à partir de quel nombre de mots-clefs on abandonne la sélection dans une liste au profit d’une recherche
- 14498 : éviter une erreur fatale pour cause de double inclusion de url/propres via qs ou propres2
- 14508 : ne pas divulguer le login et pass à la base de données aux non webmestre qui n’y ont a priori pas accès
- 14517 : permettre la modification du choix d’apparaître dans la liste des connectés au seul auteur concerné
- 14550 et 14551 : renforcer les vérifications faites sur les mots-clés, en concentrant la logique dans autoriser()
- 14558 : supporter les formats open xml de microsoft
- 14561 : styler comme les autres les liens présents dans la description d’un plugin
- 14567 : ajouter un "rel=’nofollow’" sur toutes les pages du calendrier, afin de contrer les robots qui grèvent les performances
- 14572 : lancer un login automatique en fin d’installation
- 14589 : réparer la conversion des urls en urls absolues dans les fichiers css compactés
- 14592 : éviter que l’ajax de config_fonctions provoque l’erreur "config_fonctions n’existe pas"
- 14599 : utiliser un GROUP BY simple, beaucoup plus performant en MYSQL, et qui évite à Oracle de râler car on ne peut y faire de GROUP BY sur un BLOB
- 14605 et 14614 : accepter plusieurs groupes possibles de recherche de mots-clés
- 14608 et 14622 : ajouter les méthodes retrouver_login et informer_login à l’api AUTH et passer en globale le tableau des noms des attributs potentiellement porteurs du login
- 14612 : gestion de la redirection lorsqu’on arrive déjà loggé sur le formulaire de login (ie retour d’une identification SSO) ; déléguer à traiter() le soin de calculer la redirection et appliquer éventuellement
- 14626 : permettre à un SSO de revenir sur le login avec un message d’erreur dans var_erreur
- 14628 : utiliser redbot.org comme interface de test des entêtes
- 14635 : reparer
- 14640 : supprimer un spip_log obsolète
- 14645 : permettre la suppression de la vignette du document
- 14646 et 14647 : correction d’une boucle infernale (cas où un article peut avoir des dizaines de milliers de forums -forum.spip.org par exemple-)
- 14660 : affichage des messages d’erreur avant les input dans le formulaire de login
- 14663 : affichage des erreurs en retour du formulaire editer_auteur
- 14668 : affichage du bon message pour les auteurs à la poubelle qui tentent de s’inscrire à nouveau
- 14669 : éviter de faire des sql_delete à tout va sur un calcul de page
- 14671 : utilisation de l’écriture ldaps://{{serveur}}} comme premier argument de ldap_connect pour une connexion LDAP cryptée sur un autre port que le 389
- 14673 et 14676 :utilisation des api existantes pour que les plugins puissent faire leur travail
- 14677 :éviter les cookies enregistrant des forums vides
- 14678 : prise en compte des constantes _INSTALL_USER_LDAP et _INSTALL_PASS_LDAP à l’installation ; affichage des messages signalant que l’étape courante a été franchie avec succès ; meilleur contrôle d’erreur
- 14680 : correction du filtre inserer_attribut : support des tags fermés sans espace avant />
- 14682, 14683, 14684, 14685, 14686, 14687, 14688, 14689 et 14690 : mise en conformité pour php 5.3.0
- 14695 : correction d’une chaîne de langue